0

MikroTik - Configurar Tunnel VPN

por
Raul Aragon
on 21/07/17 15:28 139 vistas
Nivel: Intermedio

Nota Importante:

Para la configuración de un Tunnel PPTP se requiere montar un servidor que acepte las conexiones remotas y por lo tanto se requiere la apertura del puerto que utiliza el Tunnel PPTP el cual es (TCP)1723.

Información:

En este articulo se explicara como realizar la configuración del un Tunnel VPN a través del Protocolo PPTP.

Diagrama de Conexión:












Configuración del equipo Servidor:

1.- Lo primero es habilitar el servicio de PPTP. Accederemos en el Winbox en la opción PPP
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.- En la ventana de PPP tenemos el botón PPTP Server en el cual habilitaremos el Servidor. 
 



 
 
 
 
 
 
 
 
 
 
  
 
3.- En PPTP Server lo único que tenemos que hacer es habilitar el Check Box de Enable y dar clic en el botón "OK"

 

 
 
 
 
 
 
 
 
 
 
 
 
4.- Ahora tendremos que cambiarnos a la pestaña de Secrets para de esta forma dar clic al botón ADD (+) para crear un nuevo
 usuario para que se conecte al servidor
 

 

 

 


 
 
 
 
 
5.- En la ventana de New PPP Secret introduciremos los parámetros correspondiente a una cuenta de Usuario.
 
En la parte Local Address se especifica la dirección IP que tendra el Tunnel del lado del Servidor y en Remote Address es la IP que tendra el Tunnel del lado del Cliente. 

 


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6.- Como podemos ver aquí tenemos como quedaría el secret creado.

 
 
 
 
 
 
 


Sintaxis de Código:

/interface pptp-server server set enabled=yes
/ppp secret add local-address=1.0.0.1 name=user password=password remote-address=1.0.0.2 service=pptp

Configuración del equipo Cliente:

1.- Lo primero es habilitar el servicio de PPTP. Accederemos en el Winbox en la opción PPP.
 

 

 

 

 

 


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2.- En la ventana de PPP en estando en la Pestaña Interface, daremos clic en ADD (+) para agregar una interface PPTP Client.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3.-En New Interface en la Ventana General especificaremos el Nombre que tendrá el Tunnel, este nombre aparecerá tanto en el Cliente como en el Servidor.
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4.-En la pestaña Dial Out, es donde especificaremos los parámetros para conectarnos al Servidor. 
 
En el Connect To: podremos especificar la dirección IP publica del Servicio de Internet al que esta conectado el Servidor, o si no se tiene una IP Fija se puede especificar un Nombre de Dominio (DDNS), y por ultimo damos clic en el botón "OK"
   


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
De esta forma nuestro enlace por Tunnel esta realizado. Como podemos observar en la lista de interfaces deberá aparecer una letra "R" que significa que el Tunnel esta "Running".

Sintaxis de Código:

* Nota Importante: reemplazar "IP ó DDNS" con la dirección IP o el Nombre de Dominio.

/interface pptp-client add connect-to=IP ó DDNS disabled=no mrru=1600 name=Tunnel-PPTP password=password profile=default user=user
 
 
 
 
 
 
 
 
 
 
 
 
 
 
En el equipo Server podemos ver que se genera una interface Dinámica en la sección PPP Interfaces, donde tiene las Letras 
"D" dinamic y "R" running


 

 

 

 

 

 


Comunicación entre Redes a través del Tunnel

1.-Para configurar las Redes LAN de los Routers hay que dirigirse a los siguientes Artículos:
2.-Una vez que el tunnel esta activo veremos en las ventanas de IP Address que se asignaran las direcciones IP a cada extremo del Tunnel "Server-Client"
Direcciones IP Servidor                                          Direcciones IP Cliente
  
 
3.-Ahora se realizara el enrutamiento de la Red del equipo Servidor hacia la red del equipo Cliente, para esto accederemos desde nuestro Winbox a IP => Routes
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.-En la ventana de Routes tenemos las rutas de nuestra Red LAN necesitaremos registrar una nueva ruta estática, dando clic en el botón ADD(+)

 
 
 
 
 
 
 
 
 
 
 

5.-En la ventana de New Route al encontrarnos en el Server tenemos que agregar la Dirección Destino que tiene la Red que esta manejando el Router Cliente y el Gateway es la Dirección IP que tiene la interface del Tunnel del lado del Cliente y damos clic en  el botón "OK"
 
 


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Al final en nuestra tabla de rutas tendremos el destino a la Red Local y a la Red Remota, por este motivo los dos sitios no pueden manejar la misma Red Local.

Sintaxis de Código:

/ip route add distance=1 dst-address=192.168.1.0/24 gateway=1.0.0.1

 
 
 
 
 
 
 
 
 
 
 
 
 
6.-Ahora se realizara el enrutamiento de la Red del equipo Cliente hacia la red del equipo Servidor, para esto accederemos desde nuestro Winbox a IP => Routes

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
7.-En la ventana de Routes tenemos las rutas de nuestra Red LAN necesitaremos registrar una nueva ruta estática, dando clic en el botón ADD(+)
Nuevo artículo

Mantener informado